[FROG] Redistribute to BGP ipv4 labeled-unicast

Marco Marzetti marco at lamehost.it
Tue Jul 24 04:43:24 EDT 2018


Hello Renato,

"redistribute connected" works along with static label bindings.
Thanks!

But my original plan was to redistribute OSPF to BGP-LU .
Is that supported?

I tried to setup a small OSPF network and to run LDP on top of it.
Result is FRR is learning few labels:

frr# show mpls table
 Inbound                            Outbound
   Label     Type          Nexthop     Label
--------  -------  ---------------  --------
      16      LDP       192.0.2.10         3
      17      LDP       192.0.2.10        16
      18      LDP       192.0.2.10         3

frr# show ip route 192.0.2.3/32
Routing entry for 192.0.2.3/32
  Known via "ospf", distance 110, metric 111, best
  Last update 00:31:08 ago
  * 192.0.2.10, via eth1, label 16

frr# show mpls table 17
Local label: 17
 type: LDP remote label: 16 distance: 150
  via 192.0.2.10 dev eth1


BGP is configured to redistribute connected and OSPF
!
router bgp 64496
 no bgp default ipv4-unicast
 coalesce-time 1000
 neighbor 198.51.100.2 remote-as 64497
 !
 address-family ipv4 unicast
  redistribute connected
  redistribute ospf
 exit-address-family
 !
 address-family ipv4 labeled-unicast
  neighbor 198.51.100.2 activate
 exit-address-family
!
router ospf
 passive-interface lo
!

And i see prefixes in RIB:
frr# show bgp ipv4 unicast
BGP table version is 6, local router ID is 192.0.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, =
multipath,
              i internal, r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.0.2.1/32     0.0.0.0                  0         32768 ?
*> 192.0.2.2/32     192.0.2.10             101         32768 ?
*> 192.0.2.3/32     192.0.2.10             111         32768 ?
*> 192.0.2.8/30     0.0.0.0                  0         32768 ?
*> 192.0.2.12/30    192.0.2.10             110         32768 ?
*> 198.51.100.0/30  0.0.0.0                  0         32768 ?

Displayed  6 routes and 6 total paths
frr# show bgp ipv4 labeled-unicast
No BGP prefixes displayed, 0 exist
frr#

But the only one that is advertised to 198.51.100.2 is 192.0.2.1/32
(connected) and only when i set static bindings:
mpls label bind 192.0.2.1/32 100
mpls label global-block 16 1000

Thank you

Regards


On Mon, Jul 23, 2018 at 10:01 PM Renato Westphal <
renato at opensourcerouting.org> wrote:

> You need to configure static MPLS bindings for the connected routes.
>
> Please try this:
>   mpls label global-block 16 1000
>   mpls label bind 192.0.2.8/32 101
>   mpls label bind 192.0.2.2/30 102
>
> On Mon, Jul 23, 2018 at 4:59 PM, Renato Westphal
> <renato at opensourcerouting.org> wrote:
> > You need to configure static MPLS bindings for the connected routes.
> > Please try this:
> >
> >
> > On Mon, Jul 23, 2018 at 4:54 PM, Marco Marzetti <marco at lamehost.it>
> wrote:
> >> Hello Renato,
> >>
> >> Are you sure about that?
> >>
> >> Configuration is:
> >> !
> >> interface eth0
> >>  ip address 192.0.2.2/30
> >> !
> >> interface lo
> >>  ip address 192.0.2.8/32
> >> !
> >> router bgp 64497
> >>  no bgp default ipv4-unicast
> >>  coalesce-time 1000
> >>  neighbor 192.0.2.1 remote-as 64496
> >>  !
> >>  address-family ipv4 unicast
> >>   network 192.0.2.8/32
> >>   redistribute connected
> >>  exit-address-family
> >>  !
> >>  address-family ipv4 labeled-unicast
> >>   neighbor 192.0.2.1 activate
> >>  exit-address-family
> >> !
> >>
> >> And 192.0.2.1 is not receiving any routes
> >>
> >> Regards
> >>
> >> Marco
> >>
> >> On Mon, Jul 23, 2018 at 6:18 PM Renato Westphal
> >> <renato at opensourcerouting.org> wrote:
> >>>
> >>> Hi Marco,
> >>>
> >>> In the FRR BGP-LU implementation, both the unicast and labeled-unicast
> >>> SAFIs share the same routing table. So if you use the "network" and
> >>> "redistribute" commands under "address-family ipv4 unicast", the
> >>> redistributed routes will be assigned a local label if one is
> >>> configured in zebra (BGP-LU doesn't support dynamic labels yet).
> >>>
> >>> Example:
> >>>   address-family ipv4 unicast
> >>>    network 1.1.1.1/32
> >>>    no neighbor 10.0.1.2 activate
> >>>   exit-address-family
> >>>   !
> >>>   address-family ipv4 labeled-unicast
> >>>    neighbor 10.0.1.2 activate
> >>>    exit-address-family
> >>>   !
> >>>
> >>> Unfortunately we don't have documentation for BGP-LU yet since it's a
> >>> relatively new feature. In case it helps, here's my BGP-LU test
> >>> topology:
> >>> https://gist.github.com/rwestphal/9707df2ff6c2073c8b46a23e7d603859
> >>>
> >>> Regards,
> >>> Renato.
> >>>
> >>> On Fri, Jul 20, 2018 at 5:08 AM, Marco Marzetti <marco at lamehost.it>
> wrote:
> >>> > Dear members of the group,
> >>> >
> >>> > I've noticed neither "redistribute" nor "network" commands are
> supported
> >>> > by
> >>> > bgpd for AFI/SAFI ipv4 labeled-unicast.
> >>> >
> >>> > I took a look at github and i can't find the features in any of the
> >>> > milestones.
> >>> > Is there an underlying reason i can't spot or is it just the dev team
> >>> > hasn't
> >>> > found time yet?
> >>> >
> >>> > Thank you for your help.
> >>> >
> >>> > Regards
> >>> >
> >>> > _______________________________________________
> >>> > frog mailing list
> >>> > frog at lists.frrouting.org
> >>> > https://lists.frrouting.org/listinfo/frog
> >>> >
> >>>
> >>>
> >>>
> >>> --
> >>> Renato Westphal
> >>
> >>
> >>
> >> --
> >> Marco
> >
> >
> >
> > --
> > Renato Westphal
>
>
>
> --
> Renato Westphal
>


-- 
Marco
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.frrouting.org/pipermail/frog/attachments/20180724/d7eced68/attachment.html>


More information about the frog mailing list