[FROG] Configured AFI/SAFIs do not overlap

Manuel Schweizer manuel.schweizer+frr at cloudscale.ch
Wed Jun 19 11:03:29 EDT 2019


Hey Andre

I am not sure whether this will solve your problem, but it always helps me to set up sessions more "explicitly" avoiding MP incompatibilities. That's why I always use `no bgp default ipv4-unicast` in my bgp configs along with explicit `neighbor XXX.XXX.XXX.XXX activate` or `neighbor xxxx:xxxx:xxxx:xxxx::x activate` in the respective address-family sections.

Example:

***

router bgp 397033
no bgp default ipv4-unicast
[...]
!
address-family ipv4 unicast
  neighbor XXX.XXX.XXX.XXX activate
  [...]
exit-address-family
!
address-family ipv6 unicast
  neighbor xxxx:xxxx:xxxx:xxxx::x activate
  [...]
exit-address-family

***

I hope that helps. Please accept my apologies in case I misunderstood.

Cheers,
Manuel

-- 
Manuel Schweizer

cloudscale.ch AG
Venusstrasse 29
CH-8050 Zürich

Fon: +41 44 55 222 55
Fax: +41 44 55 222 56
Web: https://www.cloudscale.ch



> On 19 Jun 2019, at 16:26, Andre Roberge <andre.roberge at maskicom.net> wrote:
> 
> 
> Hi everyone, 
> 
> I am new to frr, sorry if this is not the right place for this question. 
> 
> I’m trying to peer with my providers in IPv4 and IPv6, the IPv4 part is working great but I get an error on IPv6.
> 
> Any help would be greatly appriciated !
> 
> Andre Roberge
> andre.roberge at maskicom.net
> 
> 
> 
> 2019/06/19 09:54:45 BGP: 2607:fa48:f000:1b::1 OPEN has Prefixlist (old) ORF capability as Both for afi/safi: 2/1
> 2019/06/19 09:54:45 BGP: [EC 33554451] 2607:fa48:f000:1b::1 [Error] Configured AFI/SAFIs do not overlap with received MP capabilities
> 2019/06/19 09:54:45 BGP: %NOTIFICATION: sent to neighbor 2607:fa48:f000:1b::1 2/7 (OPEN Message Error/Unsupported Capability) 6 bytes 01 04 00 02 00 01
> 2019/06/19 09:54:45 BGP: [EC 33554451] bgp_process_packet: BGP OPEN receipt failed for peer: 2607:fa48:f000:1b::1
> 2019/06/19 09:54:45 BGP: 2607:fa48:f000:1b::1 [FSM] BGP_Stop (OpenSent->Idle), fd 23
> 2019/06/19 09:54:45 BGP: bgp_fsm_change_status : vrf 0, established_peers 1
> 2019/06/19 09:54:45 BGP: 2607:fa48:f000:1b::1 went from OpenSent to Deleted
> 
> Here is the Router Config 
> 
> Current configuration:
> !
> frr version 7.0RPKI
> frr defaults traditional
> hostname vr1.maskicom.io
> log file /var/log/frr/bgpd.log
> no ip forwarding
> no ipv6 forwarding
> !
> debug bgp keepalives
> debug bgp neighbor-events
> debug bgp nht
> debug bgp update-groups
> debug bgp updates in
> debug bgp updates out
> debug bgp zebra
> !
> router bgp 397033
>  bgp router-id XXX.XXX.XXX.XXX
>  bgp log-neighbor-changes
>  bgp deterministic-med
>  neighbor XXX.XXX.XXX.XXX remote-as 5769
>  neighbor XXX.XXX.XXX.XXX password XXXXXX
>  neighbor XXX.XXX.XXX.XXX interface eth0
>  neighbor XXX.XXX.XXX.XXX update-source eth0
>  neighbor xxxx:xxxx:xxxx:xxxx::x remote-as 5769
>  neighbor xxxx:xxxx:xxxx:xxxx::x interface eth0
>  neighbor xxxx:xxxx:xxxx:xxxx::x update-source eth0
>  !
>  address-family ipv4 unicast
>   network 23.154.32.0/24
>   network 207.253.254.0/24
>   neighbor XXX.XXX.XXX.XXX remove-private-AS
>   neighbor XXX.XXX.XXX.XXX prefix-list in-filter in
>  exit-address-family
>  !
>  address-family ipv6 unicast
>   network 2602:fe36::/36
>   neighbor 2607:fa48:f000:1b::1 remove-private-AS
>  exit-address-family
> !
> ip prefix-list in-filter seq 5 deny 0.0.0.0/0
> ip prefix-list in-filter seq 10 deny 0.0.0.0/8 le 32
> ip prefix-list in-filter seq 15 deny 10.0.0.0/8 le 32
> ip prefix-list in-filter seq 20 deny 100.64.0.0/10 le 32
> ip prefix-list in-filter seq 25 deny 127.0.0.0/8 le 32
> ip prefix-list in-filter seq 30 deny 169.254.0.0/16 le 32
> ip prefix-list in-filter seq 35 deny 172.16.0.0/12 le 32
> ip prefix-list in-filter seq 40 deny 192.0.0.0/24 le 32
> ip prefix-list in-filter seq 45 deny 192.0.2.0/24 le 32
> ip prefix-list in-filter seq 50 deny 192.168.0.0/16 le 32
> ip prefix-list in-filter seq 55 deny 198.18.0.0/15 le 32
> ip prefix-list in-filter seq 60 deny 198.51.100.0/24 le 32
> ip prefix-list in-filter seq 65 deny 203.0.113.0/24 le 32
> ip prefix-list in-filter seq 70 deny 224.0.0.0/3 le 32
> ip prefix-list in-filter seq 75 deny 0.0.0.0/0 ge 25
> ip prefix-list in-filter seq 80 permit 0.0.0.0/0 le 32
> !
> line vty
> !
> end
> 
> 
> 
> 
> _______________________________________________
> frog mailing list
> frog at lists.frrouting.org
> https://lists.frrouting.org/listinfo/frog




More information about the frog mailing list