[dev] gcc error in Configure

Donald Sharp sharpd at cumulusnetworks.com
Thu Nov 30 10:09:11 EST 2017

Mostafa -

We would need to see the config.log file to really comment, but my
first guess would be do you have gcc-4.8 installed?


On Tue, Nov 28, 2017 at 10:55 AM, Mostafa Salari <msgm68 at gmail.com> wrote:
> Hi
> I tried to install FRR on my own ubuntu1704, with the following
> configuration:
> sudo ./configure LIBS="-L/usr/lib/ -lpthread -ldl -lpq" CC=gcc-4.8
> --sysconfdir=/usr/local/myrouter  --localstatedir=/usr/local/myrouter/state
> --enable-vtysh --disable-babel --enable-fpm  --enable-group=rahyab
> --enable-user=rahyab --disable-doc
> but the following error raised with c compiler error (in config.log)
> gcc-4.8: error: unrecognized command line option '-qversion'
> gcc-4.8: fatal error: no input files
> I tried gcc-6 also!
> How can i proceed :)
> Thanks
> _______________________________________________
> dev mailing list
> dev at lists.frrouting.org
> https://lists.frrouting.org/listinfo/dev

More information about the dev mailing list