[FROG] EIGRP - Zebra version mismatch

Crypto.Troop crypto.troop at gmail.com
Mon Jun 26 21:38:52 EDT 2017


Thanks! I have it running on a clean install of Ubuntu. I had to fix up a
couple install details. I'd like to offer up my install notes to the Github
repo for Ubuntu Server 17.04

On Mon, Jun 26, 2017 at 9:00 AM Donald Sharp <sharpd at cumulusnetworks.com>
wrote:

> Crypto.Troop -
>
> This error looks like some sort of install issue.  Those error message
> indicates to me that eigrp is not actually running.
>
> Things that I would do:
>
> 1) Make sure FRR is completely turned off:
>
> ps -ef | grep quagga
> ps -ef | grep frr
> <kill -9....>
>
> 2) Make sure I am actually building what I think I am:
>
> In FRR directory:
> make distclean
> ./bootstrap.sh
> ./configure....
>
> 3) Make sure that I have installed what I think I have:
>
> sudo make install
>
> 4) Ensure that we are actually running the right version of FRR.
>
> <replace /usr/lib/frr with whatever you installed it into, if different>
>
> /usr/lib/frr/zebra ....
> /usr/lib/frr/eigrpd
>
> Now after all of that and you still have the issue, we'll take the next
> steps.
>
> donald
>
> On Sat, Jun 24, 2017 at 9:06 PM, Crypto.Troop <crypto.troop at gmail.com>
> wrote:
> > Hi,
> >
> > With EIGRP I am receiving these messages:
> > EIGRP: zclient_read: socket 12 version mismatch, marker 0, version 0
> >
> > I cannot seem to manage EIGRP via vtysh. I add "router eigrp 1" and a
> > "network x.x.x.x/24" and show run fails to show any EIGRP configs.
> > I can telnet to EIGRP's TCP socket, but no matter what configuration I
> put
> > in, there seems to be no outbound Hello's when I tcpdump my LAN
> interface.
> >
> > Other routing daemons such as BGPD are working fine with no errors.
> >
> > I installed per this:
> >
> https://github.com/FRRouting/frr/blob/master/doc/Building_FRR_on_Ubuntu1604.md
> >
> > I am manually running it with
> > /usr/lib/frr/eigrpd -u frr -g frr --vty_socket /var/run/frr/ -i
> > /var/run/frr/eigrpd.pid -z /var/run/frr/zebra.vty -f /etc/frr/eigrpd.conf
> >
> > Any ideas?
> > Thanks
> >
> >
> >
> > _______________________________________________
> > frog mailing list
> > frog at lists.frrouting.org
> > https://lists.frrouting.org/listinfo/frog
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.frrouting.org/pipermail/frog/attachments/20170627/27f3600f/attachment.html>


More information about the frog mailing list