[FROG] Originating Default EVPN Type-5 Routes with frr

Martin Mailand martin at tuxadero.com
Wed Jul 11 07:34:41 EDT 2018


Hello,

I am playing around with FRR and EVPN. My setup is very simple, I have two virtual machines running Linux, which are connected back to back and are called border leaf and normal leaf.
I have compiled FRR from git head with the option --enable-cumulus. Type 2,3,5 routes are working in a symmetric routing environment. 

Now I want to inject a default route from the border leaf, which should be a type 5 route and it should be written down to the vrf of the normal leaf.

But the documentation is a bit sparse, according to the cumulus docs it should go into the vrf part of the bgp configuration:

—snip—
switch(config)# router bgp 650030 vrf vrf1
switch(config-router)# address-family l2vpn evpn
switch(config-router-af)# default-originate ipv4
switch(config-router-af)# default-originate ipv6
switch(config-router-af)# exit
switch(config-router)# exit
switch(config)# exit
switch# write memory
—snap—

source: https://docs.cumulusnetworks.com/display/DOCS/Ethernet+Virtual+Private+Network+-+EVPN

But with this configuration I do not see any default type 5 routes in the RIB.

If I put the statements "default-originate ipv(4|6)“ into the main bgp section I get routes in the RIB. But I do not know how to read the RD (as2 0:0)
And the two default routes are not in the VRF FIB either.

Border leaf RIB:

show bgp l2vpn evpn
Route Distinguisher: as2 0:0

*> [5]:[0]:[0]:[0.0.0.0]
                    0.0.0.0                            32768 i
*> [5]:[0]:[0]:[::] 0.0.0.0                            32768 i

Normal leaf RIB:

Route Distinguisher: as2 0:0

*>i[5]:[0]:[0]:[0.0.0.0]
                    192.168.0.3                   100      0 i
*>i[5]:[0]:[0]:[::] 192.168.0.3                   100      0 i

Any hint would be appreciated to get it up and running.

Thanks for your time.


Best regards, 
 martin


Here the two configs.

border leaf:

vrf vrf1
 vni 8000
!
# VRF1
router bgp 1234 vrf vrf1
!
 bgp router-id 192.168.10.3
 !
 address-family ipv4 unicast
  redistribute connected
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute connected
 exit-address-family
 !
 address-family l2vpn evpn
  advertise ipv4 unicast
  advertise ipv6 unicast
  # should be here according to the cumulus docs
  # default-originate ipv4
  # default-originate ipv6
 exit-address-family
!
## Global
router bgp 1234
 bgp router-id 192.168.10.3
 neighbor 192.168.0.4 remote-as 1234
 #redistribute connected route-map loopbacks
 network 192.168.10.3/32
 !
 address-family l2vpn evpn
  neighbor 192.168.0.4 activate
  advertise-all-vni
  default-originate ipv4
  default-originate ipv6
 exit-address-family
!
route-map loopbacks permit 10
 match interface lo
!

Normal leaf:

vrf vrf1
 vni 8000
!
# VRF1
router bgp 1234 vrf vrf1
!
 bgp router-id 192.168.10.4
 !
 address-family ipv4 unicast
  redistribute connected
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute connected
 exit-address-family
 !
 address-family l2vpn evpn
  advertise ipv4 unicast
  advertise ipv6 unicast
 exit-address-family
!
# Global
router bgp 1234
 bgp router-id 192.168.10.4
 neighbor 192.168.0.3 remote-as 1234
 # redistribute connected route-map loopback
 network 192.168.10.4/32
 !
 address-family l2vpn evpn
  neighbor 192.168.0.3 activate
  advertise-all-vni
 exit-address-family
!
route-map loopbacks permit 10
 match interface lo
!






More information about the frog mailing list