[FROG] BGP state shows NoNeg for IPv4 LU neighbor

Thiruvazhiyan Lakshmanan TL0041926 at TechMahindra.com
Thu Jul 12 18:04:45 EDT 2018


Hi Renato,
Thanks for the configuration, it looks good for ipv4 label unicast. We are able to advertise the ipv4 loopback address with implicit null (label 3).
Similarly we are looking for ipv6 label unicast, advertising ipv6 loopback address with explicit null (label 2), but with the next-hop of ipv4 address. This is for 6PE functionality. Are you supporting this currently? When we tried with the following configuration, looks like it is using link local IPV6 address as the next-hop the ipv6 routes. But we want to use ipv4 loopback address as the next-hop for the ipv6 routes.

Below is our running configuration,

ubuntu4-4-VM1# sh running-config
Building configuration...

Current configuration:
!
frr version 5.1-dev
frr defaults traditional
hostname ubuntu4-4-VM1
log syslog informational
!
interface bond0.21
 shutdown
!
interface lo
 ip address 10.10.100.1/32 label lo:1
 ip address 10.10.100.10/32 label lo:10
 ipv6 address 2001:1890::10:10:100:10/128
!
router bgp 65516
 neighbor 10.10.101.37 remote-as 7018
 neighbor 10.10.101.41 remote-as 7018
 !
 address-family ipv4 unicast
  redistribute connected
  no neighbor 10.10.101.37 activate
  neighbor 10.10.101.41 next-hop-self
  neighbor 10.10.101.41 soft-reconfiguration inbound
 exit-address-family
 !
 address-family ipv4 labeled-unicast
  neighbor 10.10.101.37 activate
  neighbor 10.10.101.37 next-hop-self
  neighbor 10.10.101.37 soft-reconfiguration inbound
  neighbor 10.10.101.37 route-map ADV_Lo10 out
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute connected
 exit-address-family
 !
 address-family ipv6 labeled-unicast
  neighbor 10.10.101.41 activate
  neighbor 10.10.101.41 next-hop-self
  neighbor 10.10.101.41 route-map ADV6_Lo10 out
 exit-address-family
!
ip prefix-list Lo_10 seq 10 permit 10.10.100.10/32
!
ipv6 prefix-list Lov6_10 seq 10 permit 2001:1890::10:10:100:10/128
!
route-map ADV6_Lo10 permit 10
 match ipv6 address prefix-list Lov6_10
!
route-map ADV_Lo10 permit 10
 match ip address prefix-list Lo_10
!
mpls label bind 10.10.100.10/32 implicit-null
mpls label bind 2001:1890::10:10:100:10/128 IPv6 Explict Null
mpls label global-block 16 5000
!
line vty
!
end
ubuntu4-4-VM1#

Regards, 
Thiruvazhiyan L

-----Original Message-----
From: Renato Westphal [mailto:renato at opensourcerouting.org] 
Sent: Thursday, July 12, 2018 2:25 PM
To: Thiruvazhiyan Lakshmanan
Cc: Kishore Aramalla; frog at lists.frrouting.org; ANWER, MUHAMMAD B; SHAIKH, AMAN; LINGALA, AVINASH
Subject: Re: [FROG] BGP state shows NoNeg for IPv4 LU neighbor

@Kishore Good catch on the route-map issue, but the "export vpn"
command is not required for BGP-LU, only for L3VPNs.

@Thiruvazhiyan I believe you need "redistribute connected" instead of
"redistribute static" inside the BGP IPv4 address-family section.

Here's my BGP-LU test topology:
https://gist.github.com/rwestphal/9707df2ff6c2073c8b46a23e7d603859

The BGP-LU feature was implemented before the label manager was
available in zebra, so unfortunately the static MPLS label bindings
are required for now.

[]s

On Thu, Jul 12, 2018 at 3:08 PM, Thiruvazhiyan Lakshmanan
<TL0041926 at techmahindra.com> wrote:
> Hi Kishore,
> I have your suggested configuration, but still no luck, below is my current running configuration, ultimate requirement is to advertise my loopback10 address with label value of 3 (implicit null). I also tried with other label values like 1001, still not advertising. Not sure I am missing anything else.
>
> ubuntu4-4-VM2# sh running-config
> Building configuration...
>
> Current configuration:
> !
> frr version 5.1-dev
> frr defaults traditional
> hostname ubuntu4-4-VM2
> log syslog informational
> service integrated-vtysh-config
> username cumulus nopassword
> !
> ip route 10.10.100.11/32 10.10.101.2
> !
> interface lo
>  ip address 10.10.100.11/32 label lo:10
> !
> router bgp 7018
>  neighbor 10.10.101.1 remote-as 7018
>  !
>  address-family ipv4 unicast
>   redistribute static
>   no neighbor 10.10.101.1 activate
>   export vpn
>  exit-address-family
>  !
>  address-family ipv4 labeled-unicast
>   neighbor 10.10.101.1 activate
>   neighbor 10.10.101.1 next-hop-self
>   neighbor 10.10.101.1 route-map ADV_Lo10 out
>  exit-address-family
> !
> ip prefix-list Loopback10 seq 10 permit 10.10.100.11/32
> !
> route-map ADV_Lo10 permit 10
>  match ip address prefix-list Loopback10
> !
> mpls label bind 10.10.100.11/32 implicit-null
> mpls label global-block 16 1048575
> !
> line vty
> !
> end
> ubuntu4-4-VM2#
>
> Regards,
> Thiruvazhiyan L
>
>
> -----Original Message-----
> From: Kishore Aramalla [mailto:karamalla at vmware.com]
> Sent: Thursday, July 12, 2018 1:41 PM
> To: Thiruvazhiyan Lakshmanan; Renato Westphal; frog at lists.frrouting.org
> Cc: ANWER, MUHAMMAD B; SHAIKH, AMAN; LINGALA, AVINASH
> Subject: RE: [FROG] BGP state shows NoNeg for IPv4 LU neighbor
>
> Thiruvazhiyan,
> Here is a sample configuration
>
> ip route 99.1.1.0/24 14.1.1.2
> !
> router-id 3.3.3.3
> !
> router bgp 200
>  neighbor 2.2.2.2 remote-as 200
>  neighbor 2.2.2.2 update-source 3.3.3.3
>  !
>  address-family ipv4 unicast
>   redistribute static
>   no neighbor 2.2.2.2 activate
>   export vpn   >>>>You may be missing this in your configuration
>  exit-address-family
>  !
>  address-family ipv4 labeled-unicast
>   neighbor 2.2.2.2 activate
>   neighbor 2.2.2.2 next-hop-self
>   neighbor 2.2.2.2 route-map priv_rt out
>  exit-address-family
> !
> ip prefix-list priv_rt seq 10 permit 99.1.1.0/24
> !
> route-map priv_rt permit 10
>  match ip address prefix-list priv_rt
> !
> mpls label bind 99.1.1.0/24 3001
> mpls label global-block 3001 4000
>
> Best,
> Kishore
> -----Original Message-----
> From: Kishore Aramalla
> Sent: Thursday, July 12, 2018 10:23 AM
> To: 'Thiruvazhiyan Lakshmanan' <TL0041926 at TechMahindra.com>; Renato Westphal <renato at opensourcerouting.org>; frog at lists.frrouting.org
> Cc: ANWER, MUHAMMAD B <bilal at research.att.com>; SHAIKH, AMAN <ashaikh at research.att.com>; LINGALA, AVINASH <ar977m at att.com>
> Subject: RE: [FROG] BGP state shows NoNeg for IPv4 LU neighbor
>
> Hi Thiruvazhiyan,
>
> Your route-map configuration may be a problem here. I have FRR 5.1, the options available for address match are the following.
> There is no way you can specify ip address in cidr format (10.10.100.11/32). This is treated as the access-list name.
> You may wanna use prefix-list or an access list. I used prefix-list.
>
> dev(config-route-map)# match ip address
>   (1-199)      IP access-list number
>   (1300-2699)  IP access-list number (expanded range)
>   WORD         IP Access-list name
>   prefix-len   Match prefix length of ip address
>   prefix-list  Match entries of prefix-lists
>
> Best,
> Kishore
>
> -----Original Message-----
> From: frog <frog-bounces at lists.frrouting.org> On Behalf Of Thiruvazhiyan Lakshmanan
> Sent: Thursday, July 12, 2018 8:17 AM
> To: Renato Westphal <renato at opensourcerouting.org>; frog at lists.frrouting.org
> Cc: ANWER, MUHAMMAD B <bilal at research.att.com>; SHAIKH, AMAN <ashaikh at research.att.com>; LINGALA, AVINASH <ar977m at att.com>
> Subject: Re: [FROG] BGP state shows NoNeg for IPv4 LU neighbor
>
> Thanks Renato for your reply. The NoNeg issue is resolved now. but, the route advertisement to LU neighbor is not happening. I tried to add the mpls label bind entries, still no luck.
>
> Is there any sample configuration to advertise the routes to LU peer. Is there a way to check whether the static label binding is installed in the route table before advertising into BGP.
>
> Regards,
> Thiruvazhiyan L
>
> -----Original Message-----
> From: Renato Westphal [mailto:renato at opensourcerouting.org]
> Sent: Monday, July 9, 2018 2:59 PM
> To: Thiruvazhiyan Lakshmanan
> Cc: frog at lists.frrouting.org
> Subject: Re: [FROG] BGP state shows NoNeg for IPv4 LU neighbor
>
> Hi,
>
> The NoNeg issue was fixed by this PR: https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2FFRRouting%2Ffrr%2Fpull%2F2494&data=02%7C01%7Ckaramalla%40vmware.com%7Cc7b07b8449bc4616832808d5e80aaf37%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C1%7C0%7C636670054970851853&sdata=h4qCNdUpSPYWDnL%2BUhO1FH0mP2Ra4TdqOo4zznvp%2BrE%3D&reserved=0
>
> To advertise local BGP-LU routes, I believe you must create static MPLS bindings in zebra first. Example:
>
>   mpls label global-block 1000 2000
>   mpls label bind network 10.0.0.0/8 1001
>
> Hope it helps,
> Renato.
>
> On Mon, Jul 9, 2018 at 3:50 PM, Thiruvazhiyan Lakshmanan <TL0041926 at techmahindra.com> wrote:
>> Hi,
>>
>> I am trying to use FRR in my VM for BGP 3107 functionality. While
>> configuring the BGP neighbor with address family “ipv4
>> labeled-unicast”, the neighbor state shows NoNeg. But the peer side
>> router shows established. I also noticed the routes are learnt in FRR
>> from peer router and installed in the route table. But, I am trying to
>> advertise my VM loopback to the LU neighbor, which is not happening. Can someone help me on this?
>>
>>
>>
>> Below is the VM details,
>>
>> root at ubuntu4-4-VM2:~# uname -r
>>
>> 4.16.18-041618-generic
>>
>> root at ubuntu4-4-VM2:~# lsb_release -a
>>
>> No LSB modules are available.
>>
>> Distributor ID: Ubuntu
>>
>> Description:    Ubuntu 16.04.4 LTS
>>
>> Release:        16.04
>>
>> Codename:       xenial
>>
>> root at ubuntu4-4-VM2:~#
>>
>>
>>
>> FRR version:
>>
>> Total number of neighbors 1
>>
>> ubuntu4-4-VM2# show version
>>
>> FRRouting 5.0 (ubuntu4-4-VM2).
>>
>> Copyright 1996-2005 Kunihiro Ishiguro, et al.
>>
>> configured with:
>>
>>      '--build=x86_64-linux-gnu' '--prefix=/usr'
>> '--includedir=${prefix}/include' '--mandir=${prefix}/share/man'
>> '--infodir=${prefix}/share/info' '--sysconfdir=/etc' '--localstatedir=/var'
>> '--disable-silent-rules' '--libexecdir=${prefix}/lib/frr'
>> '--disable-maintainer-mode' '--disable-dependency-tracking'
>> '--enable-exampledir=/usr/share/doc/frr/examples/'
>> '--localstatedir=/var/run/frr' '--sbindir=/usr/lib/frr'
>> '--sysconfdir=/etc/frr' '--disable-snmp' '--enable-ospfapi=yes'
>> '--enable-multipath=256' '--enable-ldpd' '--disable-tcp-zebra'
>> '--enable-fpm' '--enable-user=frr' '--enable-group=frr'
>> '--enable-vty-group=frrvty' '--enable-configfile-mask=0640'
>> '--enable-logfile-mask=0640' '--enable-werror' '--with-libpam'
>> '--enable-systemd=yes' '--enable-poll=yes' '--enable-cumulus=no'
>> '--enable-pimd' '--enable-dependency-tracking' '--enable-bgp-vnc=yes'
>> '--disable-rpki' 'CFLAGS=-g -O2 -fPIE -fstack-protector-strong
>> -Wformat -Werror=format-security' 'CPPFLAGS=-Wdate-time -D_FORTIFY_SOURCE=2'
>> 'CXXFLAGS=-g -O2 -fPIE -fstack-protector-strong -Wformat
>> -Werror=format-security' 'FCFLAGS=-g -O2 -fPIE -fstack-protector-strong'
>> 'FFLAGS=-g -O2 -fPIE -fstack-protector-strong' 'GCJFLAGS=-g -O2 -fPIE
>> -fstack-protector-strong' 'LDFLAGS=-Wl,-Bsymbolic-functions -fPIE -pie
>> -Wl,-z,relro -Wl,-z,now' 'OBJCFLAGS=-g -O2 -fPIE
>> -fstack-protector-strong -Wformat -Werror=format-security'
>> 'OBJCXXFLAGS=-g -O2 -fPIE -fstack-protector-strong -Wformat -Werror=format-security'
>> 'build_alias=x86_64-linux-gnu'
>>
>> ubuntu4-4-VM2#
>>
>>
>>
>> FRR configuration,
>>
>> ubuntu4-4-VM2# sh running-config
>>
>> Building configuration...
>>
>>
>>
>> Current configuration:
>>
>> !
>>
>> frr version 5.0
>>
>> frr defaults traditional
>>
>> hostname ubuntu4-4-VM2
>>
>> log syslog informational
>>
>> no ip forwarding
>>
>> no ipv6 forwarding
>>
>> service integrated-vtysh-config
>>
>> username cumulus nopassword
>>
>> !
>>
>> interface lo
>>
>> ip address 10.10.100.11/32 label lo:10
>>
>> !
>>
>> router bgp 7018
>>
>> neighbor 10.10.101.1 remote-as 7018
>>
>> !
>>
>> address-family ipv4 unicast
>>
>>   network 10.0.0.0/8 label-index 3
>>
>>   no neighbor 10.10.101.1 activate
>>
>> exit-address-family
>>
>> !
>>
>> address-family ipv4 labeled-unicast
>>
>>   neighbor 10.10.101.1 activate
>>
>>   neighbor 10.10.101.1 next-hop-self
>>
>>   neighbor 10.10.101.1 route-map ADV_Lo10 out
>>
>> exit-address-family
>>
>> !
>>
>> route-map ADV_Lo10 permit 10
>>
>> match ip address 10.10.100.11/32
>>
>> match source-protocol connected
>>
>> !
>>
>> line vty
>>
>> !
>>
>> end
>>
>> ubuntu4-4-VM2# sh ip bg sum
>>
>>
>>
>> IPv4 Labeled Unicast Summary:
>>
>> BGP router identifier 10.10.100.11, local AS number 7018 vrf-id 0
>>
>> BGP table version 0
>>
>> RIB entries 0, using 0 bytes of memory
>>
>> Peers 1, using 20 KiB of memory
>>
>>
>>
>> Neighbor        V         AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down
>> State/PfxRcd
>>
>> 10.10.101.1     4       7018    9337    8553        0    0    0 2d23h15m
>> NoNeg
>>
>>
>>
>> Total number of neighbors 1
>>
>> ubuntu4-4-VM2#
>>
>> ubuntu4-4-VM2# show ip bgp ipv4 labeled-unicast neighbors 10.10.101.1
>> advertised-routes
>>
>> % No such neighbor or address family
>>
>> ubuntu4-4-VM2# show ip bgp ipv4 labeled-unicast neighbors 10.10.101.1
>> received-routes
>>
>> % No such neighbor or address family
>>
>> ubuntu4-4-VM2#
>>
>> Displayed  26 routes and 26 total paths
>>
>> ubuntu4-4-VM2# sh ip route
>>
>> Codes: K - kernel route, C - connected, S - static, R - RIP,
>>
>>        O - OSPF, I - IS-IS, B - BGP, E - EIGRP, N - NHRP,
>>
>>        T - Table, v - VNC, V - VNC-Direct, A - Babel, D - SHARP,
>>
>>        F - PBR,
>>
>>        > - selected route, * - FIB route
>>
>>
>>
>> K>* 0.0.0.0/0 [0/0] via 135.21.13.161, ens3, 2d23h58m
>>
>> B>* 10.10.100.1/32 [200/0] via 10.10.101.1, bond0.11, label 306384,
>> B>2d23h58m
>>
>> B>* 10.10.100.10/32 [200/0] via 10.10.101.1, bond0.11, label 306416,
>> 2d23h58m
>>
>> C>* 10.10.100.11/32 is directly connected, lo, 2d23h58m
>>
>> C>* 10.10.101.0/30 is directly connected, bond0.11, 2d23h58m
>>
>> C>* 10.10.101.32/30 is directly connected, bond0.12, 2d23h58m
>>
>> B>* 10.10.101.36/30 [200/0] via 10.10.101.1, bond0.11, label 306432,
>> 2d23h58m
>>
>> B>* 10.10.101.40/30 [200/0] via 10.10.101.1, bond0.11, label 306368,
>> 2d23h58m
>>
>> B>* 10.10.252.1/32 [200/0] via 10.10.101.1, bond0.11, label 306048,
>> B>2d23h58m
>>
>> B>* 10.10.252.2/32 [200/0] via 10.10.101.1, bond0.11, label 306064,
>> B>2d23h58m
>>
>>
>>
>> Regards,
>> Thiruvazhiyan L
>>
>>
>>
>> ======================================================================
>> ======================================================
>>
>> Disclaimer:  This message and the information contained herein is
>> proprietary and confidential and subject to the Tech Mahindra policy
>> statement, you may review the policy at
>> https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.te
>> chmahindra.com%2FDisclaimer.html&data=02%7C01%7Ckaramalla%40vmware
>> .com%7Cc7b07b8449bc4616832808d5e80aaf37%7Cb39138ca3cee4b4aa4d6cd83d9dd
>> 62f0%7C1%7C0%7C636670054970851853&sdata=LrZOKo21Z9Dhlmb5mvITcbmYdV
>> vbj2Gh2LEp3kEmuBE%3D&reserved=0 externally
>> https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftim.te
>> chmahindra.com%2Ftim%2Fdisclaimer.html&data=02%7C01%7Ckaramalla%40vmware.com%7Cc7b07b8449bc4616832808d5e80aaf37%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C1%7C0%7C636670054970851853&sdata=s8O8Bd%2FNgevNSFwQo167xQzpQVL2GjqFRhbcvuQ%2FNso%3D&reserved=0 internally within TechMahindra.
>>
>> ======================================================================
>> ======================================================
>>
>>
>> _______________________________________________
>> frog mailing list
>> frog at lists.frrouting.org
>> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists
>> .frrouting.org%2Flistinfo%2Ffrog&data=02%7C01%7Ckaramalla%40vmware
>> .com%7Cc7b07b8449bc4616832808d5e80aaf37%7Cb39138ca3cee4b4aa4d6cd83d9dd
>> 62f0%7C1%7C0%7C636670054970851853&sdata=CZ%2BglaorkVRdVMfsHOfSt7hU
>> SKAAR%2FtE%2FmX41zq8OOQ%3D&reserved=0
>>
>
>
>
> --
> Renato Westphal
> ============================================================================================================================
>
> Disclaimer:  This message and the information contained herein is proprietary and confidential and subject to the Tech Mahindra policy statement, you may review the policy at https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.techmahindra.com%2FDisclaimer.html&data=02%7C01%7Ckaramalla%40vmware.com%7Cc7b07b8449bc4616832808d5e80aaf37%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C1%7C0%7C636670054970851853&sdata=LrZOKo21Z9Dhlmb5mvITcbmYdVvbj2Gh2LEp3kEmuBE%3D&reserved=0 <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.techmahindra.com%2FDisclaimer.html&data=02%7C01%7Ckaramalla%40vmware.com%7Cc7b07b8449bc4616832808d5e80aaf37%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C1%7C0%7C636670054970851853&sdata=LrZOKo21Z9Dhlmb5mvITcbmYdVvbj2Gh2LEp3kEmuBE%3D&reserved=0> externally https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftim.techmahindra.com%2Ftim%2Fdisclaimer.html&data=02%7C01%7Ckaramalla%40vmware.com%7Cc7b07b8449bc4616832808d5e80aaf37%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C1%7C0%7C636670054970851853&sdata=s8O8Bd%2FNgevNSFwQo167xQzpQVL2GjqFRhbcvuQ%2FNso%3D&reserved=0 <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftim.techmahindra.com%2Ftim%2Fdisclaimer.html&data=02%7C01%7Ckaramalla%40vmware.com%7Cc7b07b8449bc4616832808d5e80aaf37%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C1%7C0%7C636670054970851853&sdata=s8O8Bd%2FNgevNSFwQo167xQzpQVL2GjqFRhbcvuQ%2FNso%3D&reserved=0> internally within TechMahindra.
>
> ============================================================================================================================
> _______________________________________________
> frog mailing list
> frog at lists.frrouting.org
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.frrouting.org%2Flistinfo%2Ffrog&data=02%7C01%7Ckaramalla%40vmware.com%7Cc7b07b8449bc4616832808d5e80aaf37%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C1%7C0%7C636670054970861857&sdata=2ZQZMgIMtkg%2Bu4p9qXiYKqk8le%2FIjaKfjOtyzI9P1G0%3D&reserved=0



-- 
Renato Westphal


More information about the frog mailing list